Welcome, Guest

Author Topic: Last version of Coherent with Unity 2017  (Read 1147 times)

whimsica

  • Posts: 59
    • View Profile
Last version of Coherent with Unity 2017
« on: September 25, 2017, 09:26:06 AM »
Alexandra in Sales/Tech said that there are clients running the last version of CoherentUI with Unity 2017.

When I try nothing shows up. How do I get past this error?

Code: [Select]
Trying to create Unity3D texture renderer with invalid type = -1.

In the rendering type section it says OpenGLCore is selected first then Metal is the second choice, not sure if that has anything to do with it.

If it's possible how do I get past that error?

john.v

  • Administrator
  • *****
  • Posts: 76
    • View Profile
Re: Last version of Coherent with Unity 2017
« Reply #1 on: September 26, 2017, 01:55:21 AM »
Hi whimsica,

The error Trying to create Unity3D texture renderer with invalid type states that you are trying to use a rendering backend that Coherent doesn't support.

Since Unity 5.5, OpenGL 2 is no longer supported, so OpenGLCore is indeed the recommended graphics API in CoherentUI 2.6+ and Unity 5.5+ but there might be another rendering setting that causes the issue.

Please, submit a ticket at support@coherent-labs.com where you can send us a log with the errors and a screenshot of the Player Settings in your project so that we can further assist you.

John V.
Support Engineer at Coherent Labs

whimsica

  • Posts: 59
    • View Profile
Re: Last version of Coherent with Unity 2017
« Reply #2 on: September 28, 2017, 09:36:32 PM »
I attached a log. Hope it helps.
I have it set to OpenGLCore and default settings otherwise.

john.v

  • Administrator
  • *****
  • Posts: 76
    • View Profile
Re: Last version of Coherent with Unity 2017
« Reply #3 on: September 29, 2017, 01:02:26 AM »
Hi whimsica,

According to the log you sent us, you're running Coherent UI 2.6.2.0 which does not have support for OpenGLCore. Please, upgrade to 2.6.6.2 and let us know if everything is running fine.

John V.
Support Engineer at Coherent Labs

whimsica

  • Posts: 59
    • View Profile
Re: Last version of Coherent with Unity 2017
« Reply #4 on: September 29, 2017, 08:25:27 AM »
I upgraded and now I see that it loads a webpage. But I also get this error.
Assertion failed: OPENGL NATIVE PLUG-IN ERROR: GL_INVALID_ENUM: enum argument out of range

I found a post that said to add the code below to LogHandler.cs but it still didn't suppress the message. The message may not be coming from LogHandler.cs because I still get the error after commenting out everything in LogHandler.cs.

if (!message.EndsWith("GL_INVALID_ENUM: enum argument out of range"))
{
    UnityEngine.Debug.Log(string.Format("[Coherent UI] ({0}) {1}", severity, message));
}

whimsica

  • Posts: 59
    • View Profile
Re: Last version of Coherent with Unity 2017
« Reply #5 on: January 04, 2018, 05:59:03 PM »
Does CoherentUI 2.6.6.2 work with Unity 2017?
I'm stuck without it working since the last post.


Tony

  • Administrator
  • *****
  • Posts: 32
    • View Profile
Re: Last version of Coherent with Unity 2017
« Reply #6 on: January 12, 2018, 09:47:51 AM »
Hey whimsica,

We are going to prepare a version which officially supports Unity 2017 and send it your way as soon as it's ready.

Tony,
Support Engineer at Coherent Labs

whimsica

  • Posts: 59
    • View Profile
Re: Last version of Coherent with Unity 2017
« Reply #7 on: January 12, 2018, 10:24:53 AM »
That's great news. CoherentUI is still a great product.

Is there any upgrade path from CoherentUI to Hummingbird or GT?

Tony

  • Administrator
  • *****
  • Posts: 32
    • View Profile
Re: Last version of Coherent with Unity 2017
« Reply #8 on: January 17, 2018, 07:23:21 AM »
Hey Whimsica,

Our CSM Alex is best able to address inquiries of this kind. I believe you are already in touch with her. :)

Tony,
Support Engineer at Coherent Labs

whimsica

  • Posts: 59
    • View Profile
Re: Last version of Coherent with Unity 2017
« Reply #9 on: April 02, 2018, 01:50:15 PM »
Is there any progress on the version of Coherent that is going to work with Unity 2017?

Tags: