Welcome, Guest

Author Topic: coherent.d.ts and TypeScript 2.2  (Read 268 times)

Gabriel

  • Posts: 8
    • View Profile
coherent.d.ts and TypeScript 2.2
« on: March 21, 2017, 12:01:54 PM »
Hi There,

I upgraded to TypeScript 2.2 with coherent.d.ts and am getting 14 compile errors when building my project:

All errors are either:

TS2428   All declarations of 'Promise' must have identical type parameters
TS2314   Generic type 'Promise<T>' requires 1 type argument(s).

This appears to be occurring because there is a definition of Promise in lib.d.ts
« Last Edit: March 21, 2017, 12:04:03 PM by Gabriel »

Tags: