Welcome, Guest

Author Topic: OgreCoherentUI : Cannot open source file  (Read 1271 times)

Styvak

  • Posts: 1
    • View Profile
OgreCoherentUI : Cannot open source file
« on: May 24, 2016, 02:08:20 AM »
Hello everyone !

I'm building the plugin OgreCoherentUI find here : https://github.com/CoherentLabs/CoherentUI_Ogre3D
But I have an error : "Cannot open source file "Coherent/UI/UISystem.h"
I searched among UICoherent sources files but impossible to find it.

Do you know where I can find it ?

Thank you in advance ! :)

John

  • Coherent Labs support
  • Administrator
  • *****
  • Posts: 205
    • View Profile
Re: OgreCoherentUI : Cannot open source file
« Reply #1 on: May 25, 2016, 03:17:55 AM »
Hi Styvak,

The integration for Ogre3D has been made only for Coherent UI 1.x. The error is due to UISystem not being used in Coherent 2.x. ViewContext in Coherent Browser 2.x is the equivalent of Coherent UI 1.x’s UISystem. The changes needed for the integration are not excessive. We are open to pull request, so if you decide to update it we would be happy to verify and integrate your changes.

I will compile a guide with the changes between Coherent UI 1.x and 2.x and will attach it to this post when ready.

Edit: Here is the guide that contains more information related to the API changes and general 1.x -> 2.x migration.

Regards,
John
« Last Edit: May 25, 2016, 09:48:40 AM by John »

Tags: